Sat Nav

Faults and Technical chat for the Mazda CX-3
DaveG
Posts: 273
Joined: Sat Jul 15, 2017 3:52 pm
Location: Bournemouth

Sat Nav

Post by DaveG » Mon Nov 20, 2017 2:47 pm

My Sat Navy does not display the speed limit, it is a 2017 model with head up display which does show the speed limit. Any info would be appreciated.
CX3 Sport Nav - Petrol - Auto - safety pack - snowflake white - 2019


User avatar
jtonline
Posts: 1009
Joined: Sun Nov 22, 2015 4:26 pm
Location: Herefordshire, U.K.
Contact:

Re: Sat Nav

Post by jtonline » Mon Nov 20, 2017 7:52 pm

After selecting ^ on the map screen, select the cog symbol, then Warning Settings, then Speeding (set Visual only or Visual & Audio), then Speed Limit (set Always display or Only when speeding).
09/15 CX-3 Sport Nav, Dynamic Blue Mica, 1.5 Diesel, AWD, Automatic
My CX-3 website: http://www.jtonline.info
Have you added location & model info., including year to your CX-3 Forums profile? For help see this post: http://bit.ly/2fQzMfd


DaveG
Posts: 273
Joined: Sat Jul 15, 2017 3:52 pm
Location: Bournemouth

Re: Sat Nav

Post by DaveG » Mon Nov 20, 2017 8:45 pm

Thanks for the info jtonline
CX3 Sport Nav - Petrol - Auto - safety pack - snowflake white - 2019


1Monty
Posts: 195
Joined: Mon Nov 06, 2017 5:13 pm
Location: Essex

Re: Sat Nav

Post by 1Monty » Wed Nov 22, 2017 11:29 am

jtonline wrote:
Mon Nov 20, 2017 7:52 pm
After selecting ^ on the map screen, select the cog symbol, then Warning Settings, then Speeding (set Visual only or Visual & Audio), then Speed Limit (set Always display or Only when speeding).


While we are talking about sat navs. On mine it displays the name of the road I am in at the top left of the screen even though I am not in sat nav mode. I'm pretty sure when I was messing about with settings the other day I activated something that now shows these road names always being displayed. For the life of me I can't remember what setting it was so I can turn it on/off as required. It's an age thing ;)
SINCE FEB 2018 I NO LONGER OWN VEHICLE
CX-3 Sport Nav - 2.0L Petrol - 2017 - Manual - 2WD - Eternal Blue Metallic - Half Leather - 44.3mpg on a good day down hill with a strong wind behind 😎


alanandlyn
Posts: 164
Joined: Thu Sep 24, 2015 4:11 pm
Location: Hampshire

Re: Sat Nav

Post by alanandlyn » Fri Nov 24, 2017 1:26 pm

1Monty wrote:
Wed Nov 22, 2017 11:29 am
While we are talking about sat navs. On mine it displays the name of the road I am in at the top left of the screen even though I am not in sat nav mode. I'm pretty sure when I was messing about with settings the other day I activated something that now shows these road names always being displayed. For the life of me I can't remember what setting it was so I can turn it on/off as required. It's an age thing ;)
No you're not getting old, that's the way it works. I've found it quite handy and it's not the name of the road you're in it's the next one you pass. The only bit that annoys me is that the field is so long it blocks out the phone connection symbols.
CX-3 SportNav 2WD, Petrol Auto, Ceramic, Stone Leather :)


1Monty
Posts: 195
Joined: Mon Nov 06, 2017 5:13 pm
Location: Essex

Re: Sat Nav

Post by 1Monty » Fri Nov 24, 2017 3:41 pm

Thanks alanandlyn for your reply.

Now I know it's the norm I can stop faffing about with the settings 👍
SINCE FEB 2018 I NO LONGER OWN VEHICLE
CX-3 Sport Nav - 2.0L Petrol - 2017 - Manual - 2WD - Eternal Blue Metallic - Half Leather - 44.3mpg on a good day down hill with a strong wind behind 😎


lhcmazda
Posts: 28
Joined: Tue Nov 27, 2018 8:29 pm

Re: Sat Nav

Post by lhcmazda » Fri Sep 06, 2019 1:30 pm

I have a similar problem I set the speeding setting whilst in the AUX switch mode i.e. single press of the starter button and it displays 30 MPH on the LHS of the Sat Nav screen, then I start the engine and the 30 MPH display disappears, I then stop the engine go back into AUX mode i.e. one press of the starter button and select warning speeding and find that the facility has been switched OFF !!!!!!. No mater what I do i.e. resting the speeding setting and visual and audio warnings once I start the engine the facility is switched OFF every time. Has any one any ideas or suggestions as to what I'm doing wrong, I have set the speed limiter settings to always show, so not much more I can do. I have this morning visited the Mazda Dealer and they are investigating.


User avatar
jtonline
Posts: 1009
Joined: Sun Nov 22, 2015 4:26 pm
Location: Herefordshire, U.K.
Contact:

Re: Sat Nav

Post by jtonline » Fri Sep 06, 2019 2:56 pm

What version of the MZD-Connect Operating System is currently installed on the CMU? It would be worthwhile your dealer upgrading it to version 70.00.335C (for EU countries). Not heard of your exact issue, but I know the current version, fixes an issue whereby the Display 'Off' setting may not be kept if the ignition is switched off/on before the CMU has gone into sleep mode, and another issue where speed limits may not be shown for some narrow roads.

Also, is the setting retained if made whilst the engine is running rather than doing it with the ignition in ACC mode?
09/15 CX-3 Sport Nav, Dynamic Blue Mica, 1.5 Diesel, AWD, Automatic
My CX-3 website: http://www.jtonline.info
Have you added location & model info., including year to your CX-3 Forums profile? For help see this post: http://bit.ly/2fQzMfd


lhcmazda
Posts: 28
Joined: Tue Nov 27, 2018 8:29 pm

Re: Sat Nav

Post by lhcmazda » Fri Sep 06, 2019 4:22 pm

Thanks for your quick reply jtonline the car has just had it's first service from new and it has the latest MZD-Connect operating system Software i.e. 70.00.335 EU N which is different than the firmware you mentioned i.e. 70.00.335C. The "Speeding" setting is only accessible with the engine OFF i.e. when in the AUX position, one press of the starter button, it is the top setting on the page under the "Warning Setting", this setting is not available when the engine is running, "detailed in section 4.2.2. Owners online manual". Whilst you cannot access the "Speeding" option because it's no longer shown it does indicate on the Warning Screen when the engine is running that the option has been selected i.e. Visual and Audio warnings and Always is also correctly shown. The only problem is that once you stop the engine and go back into the "Speeding" setting the facility has been SWITCHED OFF, and consequently no speed indication on the Sat Nav Screen.
Now that you have mentioned the MZD-Connect version as 70.00.335C and mine is as mentioned 70.00.335 EU N, I wonder if this has anything to do with the problem, or could the dealer just try re installing the MZD-Connect software to see if the problem is solved. He was very attentive and mentioned that he will try the same operation on another car identical to mine and get back in touch, if he solves the problem or someone else has any ideas which I can pass on to the dealer I will up date the forum. Thanks again for your help with my problem, at my age a young energetic 79 years young, I cannot afford a speeding charge and the car is quite lively and one can easily not be aware of exceeding the speed limit so the facility is very useful.


User avatar
BWJ
Posts: 73
Joined: Mon Dec 31, 2018 10:24 pm
Location: Denmark

Re: Sat Nav

Post by BWJ » Fri Sep 06, 2019 5:47 pm

When you stop the engine and restart, the "Speeding" facility always been SWITCHED OFF, as well as cruise control.
CX3 2.0, Aut. Nav. Optimum SRC. 2019.


Post Reply

Return to “Faults & Technical”