I stop engine light will not light

Faults and Technical chat for the Mazda CX-3
Post Reply
Nosher
Posts: 16
Joined: Sun Jul 09, 2017 9:17 am
Location: Redcar

I stop engine light will not light

Post by Nosher » Wed May 27, 2020 5:59 am

Drove 50 miles yesterday and noticed my i stop not working.
The engine temperature light never came on at all.
Any ideas?

Thanks



Image

20200526_133520.jpg


March
Posts: 24
Joined: Thu May 02, 2019 3:23 pm

Re: I stop engine light will not light

Post by March » Sat May 30, 2020 12:16 pm

Did you have the aircon switched on?

User avatar
HouseSpider
Posts: 394
Joined: Thu Jan 11, 2018 11:47 am
Location: New Forest

Re: I stop engine light will not light

Post by HouseSpider » Sat May 30, 2020 12:35 pm

March wrote:
Sat May 30, 2020 12:16 pm
Did you have the aircon switched on?
The AC icon would then be the problem, not the engine light.
Sports Nav Auto Petrol 2017, 131bhp (chipped), Soul Red, Half Stone Leather, Safety Pack, Arm Rest, Auto Folding Mirror Kit, Detachable Tow Bar, HatchBag Boot Liner.
New Forest
50ish mpg

March
Posts: 24
Joined: Thu May 02, 2019 3:23 pm

Re: I stop engine light will not light

Post by March » Mon Jun 01, 2020 1:34 pm

OK, I'm probably not fully understanding your problem.
All I can say is that when my I-stop fails it's because the car is pulling too much voltage. Switching off the fan solves this.

lhcmazda
Posts: 42
Joined: Tue Nov 27, 2018 8:29 pm

Re: I stop engine light will not light

Post by lhcmazda » Mon Jun 01, 2020 7:36 pm

Have a look at the details contained in the owners manual regarding the necessary conditions required for the I-Stop to function, see this link below which is the CX-3 web owners manual explanation.

https://owners-manual.mazda.com/gen/en/ ... 10600.html

cyanstar
Posts: 13
Joined: Sat Feb 08, 2020 6:21 pm

Re: I stop engine light will not light

Post by cyanstar » Tue Jun 16, 2020 8:19 pm

^ do that lol.

I've only had my cx-3 for a few months. The iStop is the most finicky thing in it. The engine bit used to be an issue for me, but I realised this can happen if you are stopped on an incline, your engine is slightly too hot or cold - but not enough to trip the overheat sensor etc. So I just gave up. It works most of the time, but if it doesn't I pay no attention to it :p
CX-3 1.5D SE-L NAV 2015 Soul Red - UK

Post Reply