New owner but so frustrating

All Mazda CX-3 related discussions
Post Reply
Berniej
Posts: 7
Joined: Thu Jan 12, 2017 11:36 pm
Location: West Midlands, UK

New owner but so frustrating

Post by Berniej » Fri Mar 17, 2017 12:15 am

Evening guys,

I introduced myself a few weeks ago after taking delivery of my new CX3, top of the range sports nav.
Both my wife and I love the style, shape, colour etc and chose this model over the Mercedes GLA and the CX5 as our new purchase didn't warrant us going too big however, I was looking forward to an enjoyable motoring experience.

After 2 weeks of owning the car an error message kept popping g up on the dash.
I-eloop permanently illuminated with the I-stop flashing amber.
Looked at the handbook and it states, refer to Mazda tech asap.

This has been happening on and off for 3 months now.

Lancaster Mazda Birmingham have had the car back on 4 occasions to re-set everything and test the problem exists.

Latest update as it;s been a long drawn out affair.

The car was taken back last Saturday 11th March and I had yet another loan car.
The idea was for the plug in computer to establish what exactly is causing this intermittent fault and get it sorted once and for all.
Lancaster said they had spoken to Mazda Germany who said it could be the convertor or this or that and if it is the part they are thinking of it's £2500 worth of part.
Yesterday Thursday 16th I had a telephone conversation with the main Tech manager at BHam who advised that it is the convertor and they have placed an order for the part from Mazda Japan as nowhere in Europe has a stock, and so our new car is not going to be ready for at least another week.

I feel this has tarnished our Mazda experience, we've had several Japanese cars over the years without any issues at all.
I feel as though I want my money back or exchange for a CX5 and try that.

It would appear that only two people have experienced this error issue and the message intermittently popping up. Now you have been contacted by the unfortunate European CX3 member.
Grrrrrrrrrr
Mazda CX-3 2.0 150ps AWD Sport Nav Metallic Soul Red


GeeJam
Posts: 130
Joined: Mon Sep 05, 2016 3:04 pm
Location: South Lincolnshire

Re: New owner but so frustrating

Post by GeeJam » Fri Mar 17, 2017 7:15 am

Sounds like really bad luck Berniej. If I were in your shoes, I'd seek a second opinion from another Mazda dealer and keep a note of additional mileage incurred.
CX-3 Sport Nav 2.0L Petrol. Manual. Soul Red & Half Stone interior. From new Sept 2015. South Lincolnshire UK.


User avatar
anchorman
Posts: 1048
Joined: Tue Jul 07, 2015 4:23 pm

Re: New owner but so frustrating

Post by anchorman » Fri Mar 17, 2017 8:29 am

It's frustrating but sometimes these things are cured with resets and then settle down. It's a warning light and it doesn't stop the car so I'd be inclined to ignore it and stop worrying about it. The car will get fixed when the part comes. I've known people with Fords and Vauxhalls never get any satisfaction.
CX-5 Sportnav diesel auto. AWD


PeterC
Posts: 1
Joined: Thu Oct 11, 2018 6:00 pm

Re: New owner but so frustrating

Post by PeterC » Thu Oct 11, 2018 6:46 pm

My wife has had the Mazda CX3 since September 2017. It was running perfectly until the car had its first service back in August, since then the i-Stop light keeps flashing amber and on one occasion we had to call out road side assistance because it wouldn’t start.

The car has been back to the garage 4 times since it’s first service. Each time we have gotten the car back the i-Stop light will work for a few days, then it will start flashing again. The work that has been done so far includes:
- Fault diagnostics
- Front end camera replaced
- Battery has been replaced (2 weeks’s ago)

The i-Stop light has begun flashing again today and although the Mazda team are trying, the problem still persists. Unfortunately, it appears that our situation isn’t unique.

If anyone could offer any advice on how to fix this problem please let me know.


User avatar
AndyRen
Posts: 319
Joined: Fri Mar 16, 2018 12:28 pm
Location: Down a bit, down a bit more, right a bit, down a bit.... Right there - Kent

Re: New owner but so frustrating

Post by AndyRen » Fri Oct 12, 2018 8:29 am

As far as the i-eloop goes, there appears to be a recall on the unit (or connections to) as some members here have had the notification letter. Can't help any more than to say I'm sorry to hear you've had these problems. (realise Bernie's problem was way back in 2017... wonder if he/she is still suffering??)
16 plate 2L Petrol, 120bhp Soul Red Sport Nav...


steve67
Posts: 105
Joined: Sat Jun 10, 2017 10:14 am
Location: Derby

Re: New owner but so frustrating

Post by steve67 » Sun Oct 14, 2018 8:46 am

PeterC wrote:
Thu Oct 11, 2018 6:46 pm
My wife has had the Mazda CX3 since September 2017. It was running perfectly until the car had its first service back in August, since then the i-Stop light keeps flashing amber and on one occasion we had to call out road side assistance because it wouldn’t start.

The car has been back to the garage 4 times since it’s first service. Each time we have gotten the car back the i-Stop light will work for a few days, then it will start flashing again. The work that has been done so far includes:
- Fault diagnostics
- Front end camera replaced
- Battery has been replaced (2 weeks’s ago)

The i-Stop light has begun flashing again today and although the Mazda team are trying, the problem still persists. Unfortunately, it appears that our situation isn’t unique.

If anyone could offer any advice on how to fix this problem please let me know.

we have had a istop issue, the istop shuts down as it should but when you press the clutch to restart it doesn't....an you have to press the start button... since this has happened i have followed the reset process found online and touch wood this has cured it. -----

'Some time you may need to reset the i stop. press and hold till you hear 2 beeps, look on the dashboard for the yellow i stop logo , then you are good to go.'

-------

my wife drives the car 90% of the time, i have never had any issue when im driving...i will see how it goes in the next few weeks, the car was booked in for a diagnostic but have postponed it for now.


keep us informed...
One of those annoying cyclist, who happens to also drive a CX3 SPORT NAV IN ETERNAL BLUE on the odd occasion :lol: :D


Post Reply

Return to “Main Mazda CX3 chat”