USB audio tags worked now doesn't?

All Mazda CX-3 related discussions
User avatar
Thermion
Posts: 25
Joined: Mon Jun 28, 2021 9:03 am
Location: London UK

Post by Thermion » Thu Sep 09, 2021 12:18 pm

Hi, continuing my haul into the 21st Century...

So for a few months now my USB stick with mp3 collection worked fine. Was indexed and showed up properly in Albums, Songs, Artists etc. A few days ago nothing showed up in Albums, Songs, Artists etc - but all songs still are accessible from 'Folders' and play fine from there.

Removing USB stick doesn't seem to force MZD Connect to re-index when it reconnects... so the only way I have to play songs is through the folder option which isn't right and is tedious.

Help or ideas please?! All the mp3s are ID3 tagged, and it used to work...

thx in anticipation, Thermion
CX-3 Sport NAV+ AWD Auto 2019
MX-5 Mk2 1999

User avatar
jtonline
Posts: 1337
Joined: Sun Nov 22, 2015 4:26 pm
Location: Herefordshire, U.K.
Contact:

Post by jtonline » Thu Sep 09, 2021 9:55 pm

Make a note of all your preferred settings in the infotainment, then
Select SETTINGS from the Home screen
Select SYSTEM tab
Select FACTORY RESET to reset the system back to original settings, press YES to confirm.
Change any default settings back to your preferred ones & try your USB music again.
Julian.
Sept. 2015 CX-3 Sport Nav, Dynamic Blue Mica, 1.5 Diesel, AWD, Automatic
My CX-3 website: http://www.jtonline.info
Have you added location & model info., including year to your CX-3 Forums profile? See here: http://bit.ly/2fQzMfd

User avatar
Thermion
Posts: 25
Joined: Mon Jun 28, 2021 9:03 am
Location: London UK

Post by Thermion » Fri Sep 10, 2021 8:24 pm

Thank you. Would not a reset to factory clear off all the saved nav data too though?

kind regards, Thermion
CX-3 Sport NAV+ AWD Auto 2019
MX-5 Mk2 1999

Graeme67
Posts: 30
Joined: Wed Apr 14, 2021 8:37 am
Location: Sunderland UK

Post by Graeme67 » Sat Sep 11, 2021 9:03 am

Thermion wrote:
Fri Sep 10, 2021 8:24 pm
Thank you. Would not a reset to factory clear off all the saved nav data too though?

kind regards, Thermion
Your Sat Nav data is stored on the SD card which is in the dedicated slot, Not the USB stick
2017 CX 3 1.5 Diesel

st3v3cx-3
Posts: 646
Joined: Tue May 03, 2016 7:56 pm
Location: South East UK

Post by st3v3cx-3 » Sun Sep 12, 2021 9:26 pm

jtonline wrote:
Thu Sep 09, 2021 9:55 pm
Make a note of all your preferred settings in the infotainment, then
Select SETTINGS from the Home screen
Select SYSTEM tab
Select FACTORY RESET to reset the system back to original settings, press YES to confirm.
Change any default settings back to your preferred ones & try your USB music again.

Many thanks for that info JT. I'll try that on my car as I'd noticed the exact same problem as reported by the OP recently despite deleting and reloading the tracks on my USB stick.
Sport Nav Petrol Automatic FWD Arctic White plus options April 2016

st3v3cx-3
Posts: 646
Joined: Tue May 03, 2016 7:56 pm
Location: South East UK

Post by st3v3cx-3 » Mon Sep 13, 2021 9:29 pm

I tried doing a Factory Reset on my MZD Connect system today, after making a note of my preferred settings. Unfortunately, somehow the Factory Reset option under the System tab is greyed out and thus can't be actioned. :x :x :x Does anyone know what causes this and how to get round it? Otherwise I guess I'll have to contact the MZD Connect team for an explanation and solution. The OS version on my car is 70.00.021 EUN
Sport Nav Petrol Automatic FWD Arctic White plus options April 2016

User avatar
jtonline
Posts: 1337
Joined: Sun Nov 22, 2015 4:26 pm
Location: Herefordshire, U.K.
Contact:

Post by jtonline » Mon Sep 13, 2021 10:11 pm

st3v3cx-3 wrote:
Mon Sep 13, 2021 9:29 pm
...Unfortunately, somehow the Factory Reset option under the System tab is greyed out and thus can't be actioned. :x :x :x Does anyone know what causes this and how to get round it?..

If the Start/Stop button is in the ACC state, the reset option will be greyed out. You need to have the ignition on (two presses of the Start/Stop button) or have the engine running before reset can be selected.

Note that it's only my educated guess that a factory reset will cure the issue.
Julian.
Sept. 2015 CX-3 Sport Nav, Dynamic Blue Mica, 1.5 Diesel, AWD, Automatic
My CX-3 website: http://www.jtonline.info
Have you added location & model info., including year to your CX-3 Forums profile? See here: http://bit.ly/2fQzMfd

st3v3cx-3
Posts: 646
Joined: Tue May 03, 2016 7:56 pm
Location: South East UK

Post by st3v3cx-3 » Tue Sep 14, 2021 3:46 pm

jtonline wrote:
Mon Sep 13, 2021 10:11 pm
st3v3cx-3 wrote:
Mon Sep 13, 2021 9:29 pm
...Unfortunately, somehow the Factory Reset option under the System tab is greyed out and thus can't be actioned. :x :x :x Does anyone know what causes this and how to get round it?..

If the Start/Stop button is in the ACC state, the reset option will be greyed out. You need to have the ignition on (two presses of the Start/Stop button) or have the engine running before reset can be selected.

Note that it's only my educated guess that a factory reset will cure the issue.

Your guess is well educated :D I tried it with the ignition on and was then able to select the Factory Reset option and then run it. Rechecked the audio tracks on the USB afterwards and all the choices of artist / album etc were now present :) :D In rechecking the settings to customise them to my previously choices I did see that settings for certain car model options like Lane Departure and Blind Spot Monitoring, plus some others, were now selectable and changeable which weren't available with the car stop/start button in Acc. So best when making a note of the personal settings before running a Factory Reset is to note them with the car in Ignition On mode before continuing with the reset action.

NB: The height of the display in the Active Driving Display is only changeable with the car engine on as it seems it needs to be displaying something to show the change to the up or down position being made, even if you'd noted your previous personal setting you can't just make the change without the engine on :(
Sport Nav Petrol Automatic FWD Arctic White plus options April 2016

User avatar
jtonline
Posts: 1337
Joined: Sun Nov 22, 2015 4:26 pm
Location: Herefordshire, U.K.
Contact:

Post by jtonline » Tue Sep 14, 2021 3:53 pm

Great. Glad you got it sorted. That's a pint you owe me. :lol:
Julian.
Sept. 2015 CX-3 Sport Nav, Dynamic Blue Mica, 1.5 Diesel, AWD, Automatic
My CX-3 website: http://www.jtonline.info
Have you added location & model info., including year to your CX-3 Forums profile? See here: http://bit.ly/2fQzMfd

User avatar
HouseSpider
Posts: 496
Joined: Thu Jan 11, 2018 11:47 am
Location: New Forest

Post by HouseSpider » Thu Sep 16, 2021 8:54 am

And me for the 15 min I won't get back reading the post 🍺 :lol:
Sports Nav Auto Petrol 2017, 131bhp (chipped), Soul Red, Half Stone Leather, Safety Pack, Arm Rest, Auto Folding Mirror Kit, Detachable Tow Bar, HatchBag Boot Liner, Stebel Nautilus Compact horn.

Post Reply