Steering wheel cruise control mode inadvertently switched on...

Faults and Technical chat for the Mazda CX-3
Post Reply
Dogfuzz
Posts: 56
Joined: Sun Jul 15, 2018 3:34 pm
Location: SG4

Steering wheel cruise control mode inadvertently switched on...

Post by Dogfuzz » Tue Mar 12, 2019 12:42 pm

Frightening experience yesterday(monday). Cruise control got inadvertently mode(d) ON on the steering wheel( have never used it before) -and off course car naturally would not speed over 20mph. Stopped in lay-by thinking that vehicle might have been in "limp mode". Car would not restart immediately-starter button dead, all warning lights showing. Two minutes later car did start ,warning lights went out and I slowly drove the 2 miles home. After 5 mins on arrival home, discovered and exited the cruise control "on" mode on steering wheel, but the vehicle would NOT re-start.
Half an hour later with cruise control mode still OFF, all was well and vehicle started.
Vehicle started fine this morning and all behaviours fine.
Very helpful Mazda Roadside Assistance summoned who found "no faults" other than a very slight low voltage in battery( car not used on sunday)
Was this just one of those things or...?
Am monitoring carefully and am suspicious. All comments welcome
CX-3 SPORT NAV ,5 DOOR HATCHBACK,1998CC,PETROL-2018


Greenman
Posts: 332
Joined: Sun Mar 27, 2016 1:37 pm
Location: Aylesbury

Re: Steering wheel cruise control mode inadvertently switched on...

Post by Greenman » Tue Mar 12, 2019 1:13 pm

Sounds like you may have inadvertently set the speed limit function (not the cruise control).

Presumably you had the clutch disaengaged when attempting to restart - it is easy to be confused and flustered when something unexpected happens. The warning lights will show when the engine first starts - they all then go out once the car has completed its checks. If the engine is left in the "accessory" state, ie on but no running, the dash lights will be on
Sport Nav 2.0 petrol with Stone Leather


Dogfuzz
Posts: 56
Joined: Sun Jul 15, 2018 3:34 pm
Location: SG4

Re: Steering wheel cruise control mode inadvertently switched on...

Post by Dogfuzz » Tue Mar 12, 2019 6:14 pm

Very useful reply Greenman-thanks.
Been wondering if all this might be due to the sluggish low voltage in battery-eg throwing settings out etc..
Noticed this afternoon for example that my trip meter had inadvertently switched from odometer to trip B.....well...I didn't switch it and nobody else did? ....also the little green auto light on the display is now NOT on but the light stalk is in the "auto" position.
And yes-it was the speed limiting mode (not cruise control) that had been inadvertently switched on.....again...I didn't do that, neither did my wife.
I wonder if there is a battery power drain somewhere?
CX-3 SPORT NAV ,5 DOOR HATCHBACK,1998CC,PETROL-2018


User avatar
jtonline
Posts: 892
Joined: Sun Nov 22, 2015 4:26 pm
Location: Herefordshire, U.K.
Contact:

Re: Steering wheel cruise control mode inadvertently switched on...

Post by jtonline » Tue Mar 12, 2019 10:37 pm

Have you any non-mazda electrical parts fitted?

Difficult to say without checking the car over, but It's possible you have a low battery voltage issue (although you say the roadside mechanic said 'very slight'), a duff battery, a battery lead needs tightening, a broken wire somewhere... or none of the aforementioned.

I would urge you to familiarise yourself with the meaning and position of all the instrument cluster warning/information icons, so you know what's normal and what any newly lit ones mean. The speed limiter, when set, lights up a LIM icon.
09/15 CX-3 Sport Nav, Dynamic Blue Mica, 1.5 Diesel, AWD, Automatic
Have you added location & model info., including year to your CX-3 Forums profile? For help see: http://bit.ly/2fQzMfd
My Mazda CX-3 Blog: www.jtonline.info


Post Reply

Return to “Faults & Technical”